Persona - Degraded Performance

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 11:26 EDT

Identified

Persona is experiencing issues, causing increased errors, and they are investigating:

https://status.withpersona.com/incidents/01JXWJTCVR0N9E7PHQGWZVA71T
Posted Jun 16, 2025 - 11:06 EDT
This incident affected: Third Party Providers (Persona API, Persona Inquiries & Collections) and Production (Bank API).