Fireblocks - Polygon blockchain is experiencing a major outage

Incident Report for Cybrid

Resolved

Fireblocks for the Polygon blockchain transfers is now operational.
Posted Jul 30, 2025 - 14:40 EDT

Monitoring

We are currently monitoring the issue
Posted Jul 30, 2025 - 10:16 EDT
This incident affected: Third Party Providers (Fireblocks).