Crypto Transfers Are Temporary Offline

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 14:17 EST

Investigating

We are currently investigating this issue.
Posted Nov 14, 2025 - 13:20 EST
This incident affected: Production (Bank API).