Elevated errors from third party service provider

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 19:01 EDT

Identified

One of our service providers is experiencing a partial outage. They have identified the issue and preparing a fix.
Posted Jun 02, 2026 - 18:23 EDT
This incident affected: Production (Bank API).