Fiat Transfer Settlement Delays

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 17:04 EST

Identified

We are currently experiencing an outage with our partner processor, causing delays in fiat transfer settlements. We will continue to monitor the situation and notify you once the issue is resolved.
Posted Feb 25, 2026 - 13:42 EST