Production Bank API Issue
Incident Report for Cybrid
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 15:49 EDT
Investigating
We're currently seeing degraded performance in our bank API related to identity verifications.
Posted Aug 29, 2024 - 14:00 EDT
This incident affected: Production (Bank API).