Incident Affecting Quotes and Trades For BTC and USDT

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 13:50 EDT

Investigating

Attempts to get quotes for trades involving BTC or USDT are currently failing.

We are currently investigating this issue.
Posted Aug 25, 2025 - 13:30 EDT
This incident affected: Production (Bank API).