US Deposit Bank Account Creation

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 19:24 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 18:49 EDT

Identified

We've hit a rate limit with one of our providers and the team is working to resolve the situation to handle increased demand.
Posted Aug 13, 2026 - 17:03 EDT
This incident affected: Production (Bank API).