AWS US-EAST-1 Outage Affecting Settlement Times

Incident Report for Cybrid

Resolved

Services in AWS US-EAST-1 are beginning to recover and trade settlements are starting to complete.
Posted Oct 20, 2025 - 17:06 EDT

Monitoring

Due to the AWS outage in the US-EAST-1 region, we are seeing delays in settlement times coming from our liquidity providers. We are continuing to monitor the situation with AWS.
Posted Oct 20, 2025 - 12:17 EDT