USDT trade settlement delays

Incident Report for Cybrid

Resolved

We are monitoring the trades that have started settling as the liquidity provider works through their queue.
Posted Apr 10, 2026 - 13:27 EDT

Identified

We are experiencing delays in settling USDT trades due to longer than expected processing times from one of our liquidity provider partners. We are working with them to resolve the issue.
Posted Apr 10, 2026 - 11:58 EDT